svn: Mismatched FS module version for ‘fsfs’: found 1.5.1, expected 1.5.

Or maybe you’re seeing some variation of the  “svn: Failed to load module for FS type ‘fsfs'” error…

What is this?

This is what you get for taking my advice running svnserve manually. Probably an upgrade has updated the svn binaries, though an older version of svnserve is still running. Either restart svnserve yourself, or figure out how to get the fancy shmancy init scripts to work.

Note that you may be seeing this on a remote client machine, though really it’s the server that’s the problem.

Leave a Reply

Your email address will not be published. Required fields are marked *